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Introduction

A sediment budget is a measure of sediment (usually sand) “sources” (inputs), “sinks” (outputs), and
net change within a specified “control volume” (a cell or series of connecting cells) over a given
period of time. It is a fundamental planning and design tool for projects concerned with sediment
transport, deposition, and erosion.

SBAS (Sediment Budget Analysis System) for ArcGIS 10 provides a framework for formulating,
documenting, and calculating sediment budgets, including estimation of uncertainty. This
Windows application allows users to define a conceptual budget visually'by creating a series of
cells and arrows that represent sources, sinks, and flux rates. It then calculates quantitative “micro”
(local) and “macro” (regional) sediment budgets, using a pre-definéd sediment-budget equation.

SBAS Versions

Two versions of SBAS (are available:

B SBAS for ArcGIS 10—A custom toolbar. designed for use with ArcGIS/ArcMap 10 in order to
provide sediment budget capability within @ Geographic Information System (GIS) database.
(Earlier versions of this toolbar were referred toas “SBAS-A.)

B SBAS-Standalone—A standalone version ofthe application, which allows non-georeferenced
images to be used as abackground for local (“zoom-in") and regional (“zoom-out”) sediment
budgets. This application can be used only with ArcGIS/ArcMap 9.3

Files created in SBAS-Standaloné canbe brought'into SBAS for ArcGIS 10 (refer to “Using SBAS-
Standalone Files in SBAS for ArcGIS 10” on page 44), and SBAS for ArcGIS 10 files can be used in
SBAS-Standalone (refer to “Using SBAS Toolbar Files in SBAS-Standalone” on page 47).

About SBAS for ArcGIS 10

SBAS for ArcGIS 10, the subject of this manual, is designed for users who have access to existing
geospatial datasets to assist them in building sediment budgets. These datasets include such
items as georeferenced aerial photography, beach profile surveys, shoreline position data,
dredging history, coastal process, and bathymetry surveys. Provided that they are in a format
ArcMap can translate (for example, .tif, .sid, .shp, or .lyr), all pertinent information can be added to
the data frame for analysis. The data can be viewed spatially in the data frame, and its attributes
can be viewed in the associated database file.
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Requirements

ArcGIS/ArcMap 10—SBAS for ArcGIS 10 is designed to run with Esri's ArcGIS/ArcMap 10.

Microsoft .NET 4 Framework—.NET 4 is required to run the SBAS_Arc10_Tools.esriAddIn file,
which installs the SBAS Toolbar in ArcMap 10.

SBAS-Standalone—If the SBAS-Standalone version is not already installed on your
workstation, install it before installing and using the SBAS Toolbar—it isrequired because it
contains the “black box” files that perform all of the SBAS calculations: (This requirement may
be removed in a future SBAS Toolbar release.) SBAS-Standalone is@vailable at http://cirp.usace.
army.mil/products/. Click the “SBAS” tab, and then download and install.“SBAS-Standalone PC
Program.

Definitions

Alternative—A representation of one set of assumed conditions for a sediment budget.
Each alternative has its own set of fluxes, cells, placements (inputs), and removals (outputs).
Alternatives may be created to reflect different.assumptions about sediment-transport rates
and paths, and engineering activities within a budget,or they may reflect different time
periods. At least one alternative must be created in an SBAS session. Alternatives save all
values applied to cells andfluxes.

Attribute Table—Atable used to store attribute information for a specific coverage feature
class (for examplg, littoral cell, flux, and confidence layers). Each row represents a feature, and
each column denotesa field. To view a layer's attribute table, in the ArcMap Table of Contents
right-click the layer and from the pop-up menu select Open Attribute Table.

Confidence—The certainty level that the values assigned to littoral cells and fluxes are
accurate.

Feature—A point, ling, or polygon in a coverage, shapefile, or geodatabase feature class.

Flux—Representation of the input and output of sediment into a littoral cell. Each cell requires
both eastward:and westward transport rates.

Layer—A collection of similar geographic features (such as rivers, lakes, littoral cells, and
fluxes) in a particular area or place referenced together for display on a map. A layer references
geographic data stored in a data source, such as a shapefile, and defines how to display it.

Littoral Cell—A collection of information describing similar physical, biological, and cultural
characteristics within a particular area along a river, lake, sea, or ocean.

Macro Budget—A sediment budget for a region; it may consist of multiple micro budgets.
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Micro Budget—A sediment budget for a specific local area.

Sediment Budget—A measure of sediment (usually sand) “sources” (inputs), “sinks” (outputs),
and net change within a specified “control volume” (a cell or series of connecting cells) over a
given period of time.

Shapefile—A vector data storage format for storing the shape, location, and attributes of
geographic features. A shapefile is stored in a set of related files and contains one feature class.

Sink—The destination of sediment that is moved from its original location.
Source—The point of origin of sediment that is moved to a differentlocation.

Table of Contents—In ArcMap, a list of all the data frames anddayers.on the map, showing
what features the symbols in each layer represent.

Working Directory— The default location where all file§ created during an SBAS session are
stored.

Installing the SBAS Toolbar

1.

Download the SBAS Toolbar application files.

2. Double-click the SBAS_Arc10_Tools.esriAddIn file.
An Esri ArcGIS Add-In Installation Utility dialog displays.
3. (lick Install Add-int
A message box displays, stating “Installation succeeded.”
4. Click OK.
5. Open ArcMap.
6. From the Customize menu, select Add-In Manager.
An Add-In"‘Manager dialog displays. SBAS_Arc10_Tools should be listed in the My Add-Ins
section on the Add-Ins tab.
7. Click Customize.
A Customize dialog displays.
8. If necessary, click the Toolbars tab.
9. Select (check) the SBAS Toolbar check box.
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10. Click Close.

The SBAS toolbar displays on the screen.

About the SBAS Toolbar

By default, the SBAS Toolbar “floats” on the screen—that is, :
rather than being “fixed” to the top or side of the screen, itis  |Eiia iy ke
positioned somewhere on the screen and easily be dragged ltefnative ¥ Budgets ~ Edit
to other locations on the screen.

Docking the SBAS Toolbar

To “dock”the SBAS Toolbar (that is, to “fix” it to the4op, bottom, or side of the screen), drag and
drop it onto any existing toolbar or drag it to the edge of the'screen.

Undocking (“Floating”) the SBAS Zoolbar

If the SBAS Toolbar is docked and you want to undock(or Alternative * Budgets ~ Edit~ _
“float”) it, position the cursor on the left edge of the docked e
toolbar (the cursor changestoa four-way.arrow), and then drag and drop the toolbar onto the
data frame.

Displaying the SBAS,Toolbar

If, at any.time, the SBASToolbar isn’t displayed, from the ArcMap Customize menu select
Toolbars>SBAS Toolbar.
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Understanding the SBAS Toolbar

The SBAS Toolbar provides the following menus and commands.

Menu/Command/Button Function

Alternative Menu

| AF Hew flternative ‘ Creates a new alternative.

‘g Load Project Alternative ‘ Saves the current alternative file (.sbd) and loads a new
alternative file. [This function is still in‘development.]

Note: Before editing an existing'sediment budget, you must
load the alternative file associated with its.shapefiles.

2 Copy Alternative ‘ Saves a copy of the currentalternative.

Note: The attribute'table of each layer marked with the
instance of the selected alternative is automatically updated
with the name and path of the associated alternative file.

|H Save Project Alternative ‘ Saves both the ArcMap file (.mxd) and the appropriate
alternativefile (.sbd).

| P et Preferences | Customizes the working directory, measurement units, and
uncertainty method.

Budgets Menu

[J& Load SBAS Layer | Loads an SBAS layer and its associated alternative file.

‘y Convert Graphics tofSBAS Laver | Converts graphics in the data frame into littoral cell or flux

layers.

|I3I Add Graphics to Existing Lager | Adds littoral cells or flux lines to the selected layer.

Edit Menu
| B} Set Confidence | Identifies your degree of certainty that the recorded littoral
cell and flux values are correct (for example, High, Medium,
Low, No Data).

lg Show Confidence ‘ Using the layer symbology, displays on the map the
confidence level assigned to each littoral cell.

Note: The cells are outlined in confidence level colors.

| X Remove CellsjFluxes | Deletes littoral cells or flux lines from the active layer in the
Table of Contents and the alternative.

| Edit Cell{Flux Values | Allows you to edit cell or flux values in the selected layer.
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Using the SBAS Toolbar with ArcMap

For each littoral cell, flux line, and macro budget, SBAS produces a shapefile with the following

field attributes.

Note: SBAS automatically generates these attributes; in order for SBAS to calculate the residual for
the sediment budget properly, all values must be edited using the SBAS Toolbar.

A pute Applicable to pe De ptio
Cells Fluxes Macro
|

ALT_ID v 4 v String IDassigned to the alternative

ALT_NAME v 4 v String Name of the alternative associated
with the feature

CONFIDENCE v v String Uncertainly level (HighyMedium,
Low, No Data) assigned to the data

DV 4 4 Numeric [<Net change in volume within the
cell or macro budget

END_DATE v v v Date The end date of the time period
when,showing change over time in
an ArcMap time-enabled layer

ID v v v String ID assigned to the feature

NAME v v v String Name of the feature; automatically
generated, using the feature layer
name and the record number

PLACEMENT v v Numeric | Placement volume

QVALUE v Numeric | Sources and sinks to the control
volume

REMOVAL v v Numeric | Removal volume

RESIDUAL v v v Numeric | Representation of the degree to
which the cell is balanced

SBAS_FILE 4 v v String Path and file name of the
alternative related to the feature

START_DATE v v v Date The start date of the time period
when showing change over time in
an ArcMap time-enabled layer
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Creating Sediment Budgets—Overview

The basic procedure for creating micro and macro sediment budgets consists of the following
steps. Each is described in detail in the following sections.

1. Set up the data in ArcMap.

2. Set the SBAS default properties.

3. Create the littoral cells.

4. Create an alternative and littoral cell layer.

5. Edit the cells in the littoral cell layer, if necessary.

6. Create the flux lines.

7. Create a flux layer and add it to an existing alternative.
8. Edit the flux line in the flux layer, if necessary.

9. Enter the littoral cell and flux line values.

10. Identify the littoral cell layer confidence:

11. Create the macro budget.

Setting up the Data in ArcMap

Before using the SBAS Toolbar to develop a sediment budget, use the following procedure to set
up data in ArcMap.

1. If you have not done so already, open ArcMap.

2. Use the ArcMap 5 (Add Data) tool to add into the data frame the appropriate datasets to
assist you in the analysis and design of the sediment budget.

You can add vector, raster, and tabular data.
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Setting the SBAS Default Properties

Once the initial base map data has been added into the data frame, use the following procedure
to set the SBAS default properties, which determine some of the basic elements of the sediment
budget.

1. Inthe SBAS Toolbar, select Alternative>Set Preferences.
The Set Preferences dialog displays.
2. Change the following default properties, as necessary.
Note: These preferences can be changed at any point during‘an SBAS session.

B Working Directory—The default location where all SBAS alternatives andilayers/
shapefiles are stored.

Note: Layers are given the projected coordinate system'selected in the ArcMap View>Data
Frame Properties menu, Coordinate System tab.

B Measurement Units—The units’of measurement used for.all SBAS calculations.

Choices include Cubic Meters, Cubic Meters per Year, Cubic Yards, and Cubic Yards per Year.
B  Uncertainty Method—The uncertainty method used for SBAS.

Choices include Maximum and Root Mean Square.

3. Click Apply.
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Creating Littoral Cells

Littoral cells are defined by a collection of information describing similar physical, biological,
and cultural characteristics within a particular area. Littoral cell data can be in the form of a map,
database, or text.

The boundaries of the littoral cells can be defined either by morphological features (such as ebb
and flood shoals, inlet throat, and adjacent beaches) or by political features (such as nautical charts
and municipal boundaries).

Use the following procedures to draw one or more littoral cells in the ArcMap data frame.

Note: While these examples use the [ (Rectangle) and ] (Polygon) tools tocreate littoral cells,
you can also use the circle \-/ and ellipse T tools.

Note: If you need to add more cells at a later point, you can do so with the SBAS Add Graphics
to Existing Layer command. (Refer to “Add a Cell to a Littoral Celldayer” on page 19 for more
information.)

Draw Rectangular Cells

1. Inthe ArcMap Draw toolbar, click the L] (Rectangle) tool.

Note: If the Draw toolbarisn't displayed, from the Customize menu select Toolbars>Draw.
If the L] (Rectangdlle) tool isn‘t displayed, click the ¥ button to the right of the selected
shape tool and then, from the pop-up menu, select L] (Rectangle).

2. Inthe data frame, position the cursor in the upper-left corner of the new cell, press and
holddown the mouse button, and drag the rectangle to the lower-right corner.

Sediment Budget Analysis System (SBAS) for ArcGIS 10 - User’s Guide

\ Page 13 of 49
lobile Distri . »
Ennc ehE%iaL dara CESAM-OPJ-GIS

yore Document current as of March 28,2012 10:27 AM




3. Release the mouse button.

A rectangular cell displays in the data frame.

B3

SBAS Toolbar * X
alkernative » Budgets » Edit =

tool and then, from the pop-up menu, click =l Polygon.

2. Inthe data frame, click each of the new cell’s vertices (corners) except the last one.
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Double-click the new cell’s last vertex (corner).

A polygon displays in the data frame.

)
SBAS Toolbar 52 L
Alternative ~ Budgets - Edit ~

%

NN i 3

Click anywhere i ta frame to unselect the graphic.
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Creating an Alternative and a Littoral Cell Layer

Use the following procedure to create an alternative and littoral cell layer from one or more cells.
1. Select the graphic(s) you just created.

All of the cell graphics in the data frame are selected.

)

E}" Toolbar - M
ative * Budgets ~ Edit =

| £

>

3. Enter the name of the new alternative.

Note: An alternative saves all values associated with the sediment budget. Each alternative
should consist of only a single littoral cell layer and a single flux layer.
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4. Click OK.

A Convert Graphics to SBAS Layer dialog displays. The Select Alternative drop-down list box
is automatically populated with the alternative name you entered in the previous step, and
Micro is automatically selected as the Budget Layer Type.

5. [Ifitisn't already selected, in the Graphic Conversion Options section, select the Selected
Graphics radio button.

Note: Selecting the All Graphics radio button will delete all graphics nét in layers/shapefiles
(for example, arrows, labels, and other text), not only the graphics you just created and
selected.

6. Ifitisn't already selected, in the Graphic Conversion Options section, select Delete All Graphics
in View after Conversion.

Note: This option automatically deletes the graphic(s) you drew, leaving only the littoral cells.
7. To the right of the New Layer Name text box, click Browse.
A Select New Layer Folder and Name dialogdisplays.
8. Browse to the appropriate directory.
9. Inthe File Name text boX, type a name forthe new layer.
10. Click Save.

The Convert Graphics to SBAS Layer dialogredisplays, and the New Layer Name field is
populatedwith.your selection.

11. Click Create New Layer.

All\graphics are converted into a littoral cell layer, the new layer is added to the ArcMap
Table'of Contents, symbology is applied to the layer, the layer is stored in the SBAS working
directory, and a Save Alternative dialog displays. (See “Setting the SBAS Default Properties” on
page 12.)

12. In the Select Alternative to Save drop-down list box, select the alternative you identified in
step 3.

13. In the File Path/Name text box, enter the full path and file name of the alternative, or click
Browse, browse to the appropriate directory, enter a file name, and click Save.
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14. Click Save Alternative.
The data frame redisplays.

By default, when a littoral cell is created, all residual values are set to 0. Therefore, all cell colors
remain uniform until cell or flux values are edited.

Table OF Contents 1 x

i 33|48 |

=] Wisible

(€ 5BAS Layer 1 (Littoral Cell) H & [%
RESIDLIAL
Cell Loss

3

5BAS Toolbar > X
Alternative = Budgets * Edit

Cell Balance
Cell Gain
® GCWGESE4_YECTOR. GCWESE4 shoreline E =«
— <all other walues>
SUBTYPEID
— MHW
— MLLW
— ML

— NAYD_35
SBAS Layer 1_1

SBAS Layer 1.2

K3
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Editing the Cells in a Littoral Cell Layer

Add a Cell to a Littoral Cell Layer
Use the following procedure to add one or more additional cells to an existing littoral cell layer.

1. Inthe ArcMap Draw toolbar, use the [ (Rectangle) and/or Gl (Polygon) tool to add one or
more littoral cells in the ArcMap data frame.

un

Note: Refer to“” on page 12 for more information.

LR “aolbar > X
Alte > Budgets ~ Edit

BAS Layer 1_1

SHAS Lays

3. Select the graphic(s) you just created.

All of the new cell graphics in the data frame are selected.
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4. Inthe SBAS Toolbar, select Budgets>Add Graphics to Existing
Layer.
Select Layer to Edit:
| ]
An Add Graphics to Layer dialog displays.
Macro Cell Layer Options
5. From the Select Layer to Edit drop-down list box, select the _ _
Micro Budget Cell Layer:
layer to which you want to add the cells.
6. Ifitisn't already selected, In the Graphic Conversion Options Graphic Conversian Options
o o o O raphics
section, select the Selected Graphics radio button. R
. . . . elete raphics after Conversion
Note: Selecting the All Graphics radio button will delete all et M s e
graphics not in layers/shapefiles (for example, arrows, labels, T |
Add toCell Layer Cancel
and other text), not only the graphics you just created'and -
selected.
7. Ifitisn't already selected, select (check) theDelete All Graphics after Conversion check box.
8. Click Add to Cell Layer.

The selected graphic(s) are added to theispecified layer, and the data frame redisplays.

Alternative = Budgets = Edit =

SBAS Layer 11

SBAS Layer 1_2

SBAS Layer 1_3
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Resize, Reshape, and Move a Littoral Cell in a Littoral Cell Layer

Use the following procedure to resize, reshape, or move a cell in a littoral cell layer.

1. From the ArcMap Editor toolbar, select Editor>Start Editing to start an editing session.
A Start Editing dialog displays.

2. Select the littoral cell layer from the list.

3. Click OK.
The Create Features panel displays on the screen.

4. Inthe ArcMap Editor toolbar, click b (Edit Tool).

5. Select the littoral cell you want to edit.

6. Use the tools in the ArcMap Editor toolbar to resize, reshape, and/or move the cell as
necessary.

Refer to the ArcMap 10 documentation for details.
7. From the ArcMap Editor toolbar, select Editor>Stop Editing.
8. When prompted to save your changes, click Yes.

Your changes are saved, the cell.is unselected, and the Create Features pane closes.

Remove aéllfrom a Littoral Cell Layer

Use the following procedure to remove one or more littoral cells from a littoral cell layer.

—_

In the ArcMap Table of Contents, select the littoral cell layer.

2. Fromthe ArcMap Editor toolbar, select Editor>Start Editing to start an editing session.
A Start Editing dialog displays.

3. Select the littoral cell layer in the list.

4. Click OK.

A Create Features panel displays.
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5. Select the cell(s) you want to delete.

Note: To select multiple cells, click the first one and then, while holding down the Shift key,
click each additional cell.

6. Inthe SBAS Toolbar, select Edit>Remove Cells/Fluxes.

[Currently, the confirmation box lists only the first cell selected. The development team is
working on this issue.]

Note: It is imperative that you use the SBAS Edit>Remove Cells/Fluxes command to
remove cells, not the ArcMap Edit>Delete command. The SBAS command removes both
the selected cells and their related values while the ArcMap command deletes only the
cell, which will result in an incorrect sediment budget'calculation.

7. Click Yes.

The selected cell(s) are removed from the littoral cell layer, and the editing session
automatically closes.

8. If you've already saved the alternative inithis ArcMap session, this procedure ends here.

However, if you haven't yet saved the alternative in thissArcMap session and are prompted
to save the alternative,.click OK.

A Save Alternative dialog displays, prepopulated with the Alternative name and full path
and file name:

9. C(lick Save Alternative:

An Overwrite message box displays.
10. Click Yes.

A'Saved messaged box displays.
11. Click OK.

The data frame redisplays.
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Set the Cell Color and Label Options in a Littoral Cell Layer

By default, all littoral cells are 75% transparent, so any data beneath the cells can be seen.
However, cell transparency—as well as label font, size, and color—can be changed by editing
the littoral cell layer’s properties.

Note: Cells that are set to 100% transparent still exist and can be selected during an editing
session; they just don't display (except for the cell label) in the data panel.

1. In the ArcMap Table of Contents, right-click the layer name and, from the pop-up menu,
select Properties.

A Layer Properties dialog displays.
2. Click the Display tab.
3. IntheTransparent text box, type a number indicating thefransparency percentage.
4. Click the Labels tab.
5. [Ifitisn't already selected, select (check)the Label Features.in this Layer check box.

6. Inthe Text Symbol section, select the label font, size, and color.
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7. Click OK.

The map redisplays with your cell color and label choices. The following illustration shows
cell transparency set to 90% and label properties set to Arial, 8 pt, blue.

I Alternative ~ Budgets = Edit ']

SBEAS Layer 1_1

SBAS Layer 1_2

SHAS Layer 1_3

|£

=
=
[
-~
|

Creating Flux Lines

Flux linesrepresent the flow of sediment into and out of littoral cells. Using the ArcMap Draw
toolbar, you draw flux lines on the map to identify the direction of flow. Afterwards, you assign
sediment transport values to these flux lines. Each sediment budget cell requires both eastward
and westward transport rates.

Use the following, procédures to draw one or more flux lines in the ArcMap data frame.

Note: While these examples use the 4 (Line) tool to create straight and “curved” (polyline) flux
lines, you can also use the curve €33 and freehand tools to create flux lines.

Note: If you need to add more flux lines at a later point, you can do so with the SBAS Budgets>Add
Graphics to Existing Layer command. (Refer to “Add Flux Lines to a Flux Layer” on page 30 for
more information.)
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Draw Straight Flux Lines

Note: While each cell requires both eastward and westward transport rates, this example
demonstrates drawing only a single straight flux line.

1. In the ArcMap Draw toolbar, click the ™ (Line) tool.

Note: If the Draw toolbar isn’t displayed, from the Customize menu select Toolbars>Draw.
If the ™" (Line) tool isn't displayed, click the ™ button to the right of the selected shape
tool and then, from the pop-up menu, click ™" Line .

2. Inthe data frame, click the source cell.
3. Double-click the sink cell.
The two cells are connected by the line.

Note: The arrowheads of the flux lines do no
the line graphics are converted into a flux layer.

SBAS Layer 1_1

SBEAS Layer 1_3

4. Click anywhere in the data frame to unselect the line.
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Draw “Curved” Flux Lines (Polylines)
Polylines allow a line to have multiple vertices, so it can to “curve” around structures.

Note: While each cell requires both eastward and westward transport rates, this example
demonstrates drawing only a single polyline.

1. Inthe ArcMap Draw toolbar, click the s (Line) tool.

ect Toolbars>Draw.
of the selected shape

Note: If the Draw toolbar isn't displayed, from the Customize me
If the ™ (Line) tool isn't displayed, click the ™ button to the i
tool and then, from the pop-up menu, click ™" (Line) .

2. Inthe data frame, click the source cell.

3. Inthe data frame, click each of the polyline’s v s except the last one.
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4. Double-click the polyline’s last vertex on the sink cell.
The two cells are connected by the polyline.

Note: The arrowheads of the flux polylines do not display. They are not symbolized until
the polyline graphics are converted into a flux layer.

>

SBAS Toolbar r X
Alternative = Budgets = Edit ~

e

SHAS Layer 1_2

345 Layer 1_1

SHAS Layer 1_3

4
i
&3

I

me to unselect the line.
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Creating a Flux Layer and Adding it to an Existing Alternative

Use the following procedure to create a flux layer from one or more graphics and add it to an

existing alternative.
Select the line(s) you just created.

All lines in the data frame are selected.

SBAS Toolbar

Alternative = Budget A

SBAS Layer 1_2
S Layer 1_1

| >

|

2. t Budgets>Convert Graphics to SBAS Layer.
BAS Layer dialog displays. Micro is automatically selected as the
Budget Laye
3. From the Select Alternative drop-down list box, select the appropriate alternative (that is, the

one containing the littoral cell layer you created earlier).
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4. Ifitisn’t already selected, in the Graphic Conversion Options section, select the Selected
Graphics radio button.

Note: Selecting the All Graphics radio button will delete all graphics not in layers/shapefiles
(for example, arrows, labels, and other text), not only the graphics you just created and
selected.

5. [Ifitisn't already selected, in the Graphic Conversion Options section, select (check) the Delete
All Graphics in View after Conversion check box.

6. To the right of the New Layer Name text box, click Browse.
A Select New Layer Folder and Name dialog displays.
7. Browse to the appropriate directory.
8. Inthe File Name text box, type a name for the new layer.
9. Click Save.
The Convert Graphics to SBAS Layer dialogiredisplays.
10. Click Create New Layer.

All graphics are converted into aflux layer, the new layer is added to the ArcMap Table of
Contents, symbologyiis applied to the layer, the lines are transformed into arrows (with the
arrow tail indicating the source/cell and the arrow head indicating the sink cell), and the layer
is stored in the SBAS\working'directory, and,the data frame redisplays. (See “Setting the SBAS
Default Properties” on page 12.)

Note:Because Delete All Graphics After Addition was selected in the Add Graphics to Layer
dialog, the graphic(s) you drew were automatically deleted.
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Editing the Flux Lines in the Flux Layer

Add Flux Lines to a Flux Layer
Use the following procedure to add one or more additional flux lines to a flux layer.

1. In the ArcMap Draw toolbar, use the &4 tool to add one or more lines and/or polylines in
the ArcMap data frame.

Note: Refer to “Creating Flux Lines” on page 24 for more infor

[>

SBAS Layer 1_2

€

All of the line graphics in the data frame are selected.
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3. Inthe SBAS Toolbar, select Budgets>Add Graphics to Existing Layer.

An Add Graphics to Layer dialog displays.

Select Layer to Edit:

4. From the Select Layer to Edit drop-down list box, select the v
layer to which you want to add the lines.

Macro Cell Layer Options

5. [Ifitis not already selected, in the Graphic Conversion el

Options section, select the Selected Graphics radio button. |
Note: Selecting the All Graphics radio button will delete all G ot Conmersion Ontlor
. . O Al Graphi
graphics not in layers/shapefiles (for example, arrows, labels; @saecf:d gfaphics
and other text), not only the graphics you just created and
Selected. Delete &ll Graphics after Conversion

6. Ifitis not already selected, select (check) the Delete All [moatoruciayer | [ concal |
Graphics after Conversion check box.
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7. Click Add to Flux Layer.
The selected graphic(s) are added to the specified layer, and the data frame redisplays.

Note: Because Delete All Graphics After Addition was selected in the Add Graphics to
Layer dialog, the graphic(s) you drew were automatically deleted.

T

| >

SBAS Toolbar -
Alternative = Budgets = Edit =

SBAS Layer 1_2

i}

o
T,
T

SHAS Layer 1_3

£

>

A Start Editing dialog displays.
2. Select the flux layer from the list.
3. Click OK.

The Create Features panel displays on the screen.

4. In the ArcMap Editor toolbar, click LS (Edit Tool).
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5. Select the flux line you want to edit.

6. Use the tools in the ArcMap Editor toolbar to resize, reshape, and/or move the flux line as
necessary.

Refer to the ArcMap 10 documentation for details.
7. From the ArcMap Editor toolbar, select Editor>Stop Editing.

8. When prompted to save your changes, click Yes.

Remove a Flux Line from a Flux Layer

Use the following procedure to remove one or more fluxlines from a flux layer.

1. Inthe ArcMap Table of contents, select the flux layer.

2. From the ArcMap Editor toolbar, select Editor>Start Editing to start an editing session.
A Start Editing dialog displays.

3. Select the flux layer in the list.

4. Click OK.
A Create Features panel displays.

5. Select the fluxline(s) you want to deléte:

Note:To select multiple flux lines, click the first one and then, while holding down the Shift
key, click each additional flux line.

6. Inthe SBAS Toolbar, select Edit>Remove Cells/Fluxes.
A'removal confirmation message box displays.

Note: It is imperative that you use the SBAS Edit>Remove Cells/Fluxes command to
remove flux lines, not the ArcMap Edit>Delete command. The SBAS command removes
both the selected flux lines and their related values while the ArcMap command deletes
only the line, which will result in an incorrect sediment budget calculation.

7. ClickYes.

The selected flux line(s) are removed from the flux layer and the alternative, and the
editing session is automatically closed.
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8. If you've already saved the alternative in this ArcMap session, this procedure ends here.

However, if you haven't yet saved the alternative in this ArcMap session and are prompted
to save the alternative, click OK.

A Save Alternative dialog displays, prepopulated with the Alternative name and full path
and file name.

9. Click Save Alternative.

An Overwrite message box displays.
10. Click Yes.

A Saved messaged box displays.
11. Click OK.

The data frame redisplays.

Entering Littoral Cell and Flux Line Values

Enter Littoral Cell Valués
1. Inthe ArcMapTable of Contents, select the littoral cell layer.

2. Using one of the AreMap Select Features tools (I§l), select the cell you want to edit.
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3. Inthe SBAS Toolbar, select Edit>Edit Cell/Flux Values.

A Cell Properties datasheet displays.

X

u, Cell Properties

Motes

SOURCE FLUKES

SBAS Layer 2_1 0.00 0.00 | SBAS Laver 1_2

SINK FLURES
SBAS Layer2_2 0.00 0.00 O Mone
o 0.oa 0.00 O F7A,
Placerment 0.00 0.00 | P,
Removal 0.00 0.00 | M,

i Uncertainty [ Percent _

Fesidual 0.00 0.00 1]
< 4 y 4 3
[ Ok H Cahcel l ’ Apply l ’ Faorce Balanced |:E||_J l Help l

Saves changes and exits

4. Enter the appropriate values.

Note: There are various methods of abtaining these values (for example, the 3D Analyst,
Spatial Analyst, and€GlIS: Survey Toolbars).

5. Click Apply.
The value of the Residual variable is‘automatically calculated.
6. ClickOK.

The dialog closes, the residual value is posted in the Residual field of the layer’s attribute
table, and the littoral cell’s color changes according to the layer symbology in the ArcMap
Tableof Contents.

7. Repeat steps 2-6 for all other littoral cells.

Entering Flux Line Values
1. Inthe ArcMap Table of Contents, select the flux line layer.

2. Using one of the ArcMap Select Features tools (Kd), select the flux line you want to edit.
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3. Inthe SBAS Toolbar, select Edit>Edit Cell/Flux Values.

A Flux Properties datasheet displays. Flux Values | Dependencies
. Name kBaS Layeli‘
4. Enter the appropriate values.
. o Val : cu mayr
Note: There are various methods of obtaining these e E
values (for example, the 3D Analyst, Spatial Analyst, || Uncettainty | UJ

and eGlIS: Survey Toolbars). Sediment transport
rates produced from GENESIS model results can also
be imported into GIS.

Locked |

5. Click OK.

The dialog closes.

6. Repeat steps 2-5 for all other flux lines.

@R | (Corcsl] [ tovl
';

Identifying Littoral Cell Layer Confidence

At times, you may be uncertain about the values you enteredfor the littoral cells. Therefore, SBAS
lets you identify a confidencelevel for each cell.

1. Inthe SBAS Toolbaf, select Edit>Set Confidence.

2. From the Select Layer drop=down list box, select the littoral cell layer.

3. Inthe Select Record to Edit list, select the cell for which you want to set a confidence level.

4. Inthe New Value section, click the appropriate radio button (High, Medium, Low, or No Data.

5. Repeat steps 3-4 for each cell for which you want to set a confidence level.
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6. Click Show Confidence Layer.

Note: You can also click Close and then, in the SBAS Toolbar, select Edit>Show Confidence to
display the Confidence layer.

A Confidence layer is added to the ArcMap Table of Contents, and the cell outline(s) change
according to the layer symbology.

Table OF Contents W

898
= = Layers

=] SBAS Laver 2

-

=] Confidence: SBAS Layer 1
COMFIDENCE
High
Mediurn
Lo
Mo Data

ernative * Budgets v Edit~

3 Layer 1
RESIDUAL
Cell Loss
Cell Balance
Cell Gain
= GCWESEY_YECTOR. GCWG
— <all other values:
SUETYPEID
— MHY
— MLLW
— MW
— NAVD_88

SBAS Layer 1.2
SBAS Layer 1_1

< BBl

A b3

Creating a Macro Budget

After a microsediment budget has been developed using littoral cells and fluxes, a macro
sediment’budget can be created to represent it on a larger (regional) scale. The macro budget
validates assumed quantities at the boundaries of a specified group of sediment budget cells.

To construct a macro budget, define the budget for all cells that are bounded by assumed
quantities. The resulting.macro budget should balance (that is, Residual=0). If it does not
(Residual = non-zero);one or more of the assumed values must be revised.

Note: Once the macro budget has been created, the individual littoral cells can no longer be
edited unless you first delete the macro budget cell (using the same procedure as for deleting
a littoral cell). After making any necessary changes to the individual littoral cells, you must then
create a new macro budget cell.
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1. In the ArcMap Draw toolbar, click (Polygon) tool.

Note: If the Draw toolbar isn't displayed, from the Customize menu select Toolbars>Draw. If
the [ (Polygon) tool isn't displayed, click the ™ button to the right of the selected shape tool
and then, from the pop-up menu, click Polygon.

2. Inthe data frame, draw a polygon around the sediment budget area to be included in the
macro budget.

SBAT (bar S b
i tive * Budgets = Edit = 3

e
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Note: To make it easier to view the littoral cells and flow arrows inside the polygon, you can
change the polygon fill and border color using the # = (Fill) and 2 - (Line) tools. In the
following illustration, the polygon fill is set to No Color and the line to red.

Alternative * Budgets ~ Edit ~

3. Inthe SBAS Toolbar,select Budgets>Convert Graphics to SBAS Layer.

A Convert Graphics to SBAS Layer dialog displays. The Select Alternative drop-down list box is
automatically populated with,the alternative name, and “Micro”is automatically selected as
the'Budget Layer Type.

4. IntheBudget Layer Type section, make the following selections:
B Select the Macro radio button.
B In the Select Related Cell Layer drop-down list box, select the littoral cell layer.
5. Inthe Graphic Conversion Options section, select the Selected Graphics radio button.

Note: Selecting the All Graphics radio button will delete all graphics not in layers/shapefiles
(for example, arrows, labels, and other text), not only the graphics you just created and
selected.
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6. Inthe Graphic Conversion Options section, select Delete All Graphics in View after Conversion.

Note: This option automatically deletes the graphic you drew, leaving only the macro budget
cell.

7. To the right of the New Layer Name text box, click Browse.
A Select New Layer Folder and Name dialog displays.
8. Browse to the appropriate directory.
9. Inthe File Name text box, type a name for the new layer.
10. Click Save.
The Convert Graphics to SBAS Layer dialog redisplays.
11. Click Create New Layer.
A message box displays, stating “Macro Budget Successfully Created.”
12. Click OK.

The data frame redisplays. All graphics were converted into a macro budget layer, the new
layer was added to the ArcMapiTable of Contents, symbology was applied to the layer, and the
layer was stored in the'SBAS working directory. (See “Setting the SBAS Default Properties” on
page 12.)

= = Layers
= Macro Budget (Macro Budg:
RESIDUAL
| CellLoss
" Cell Balance
Cell Gain
B ¥ =BAS Layer 2
-
= | Corfidence: SBAS Layer 1
CONFIDENCE
" High
Mediurn
Low
Mo Data
= SBAS Laver 1
RESIDUAL
Cell Loss
Cell Balance
Cell Gain
= GCWGESE4_VECTOR. GCWGE
— <all other values:
SUBTYPEID
— MHW
— MLLW
— MLW
— NAVD_8

Macra Budget_1
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Saving an Alternative

While creating or editing layers, you may be prompted to save the alternative. However, you can
use the following procedure at any point to save an alternative file.

1. In the SBAS Toolbar, select Alternative>Save Project Alternative.
A Save Alternative dialog displays.
2. From the Select Alternative to Save drop-down list box, select the appropriate alternative.

3. Inthe File Path/Name text box, enter the full path and file name®f the alternative, or click
Browse, browse to the appropriate directory, enter a file name, and click Save.

4. Click Save Alternative.

5. Ifyou haven't saved the alternative before, the data frame redisplays, and this is the end of this
procedure.

However, if you've saved the alternative before and an Qverwrite message box displays, stating
“File of same name already exists. Overwrite?’, click Yes.

Note: If you want to save the alternative under adifferentfile name, click No, and then enter
the full path and file name for the new alternative, or click Browse, browse to the appropriate
directory, enter a file name, and click Save:

A“Saved” messagé box displays, stating “Alternative has been saved”
6. Click OK.

The data frame redisplays.

Saving a New Alternative

At times, you may wahnt to save your work to a new alternative to reflect different assumptions
about sediment-transport rates and paths, and engineering activities within a budget, or to reflect
different time periods.

Use the following procedure to save a new alternative.
1. Inthe SBAS Toolbar, select Alternative>New Alternative.

An Enter Alternative Name dialog displays.
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2. Inthe text box, type a name for the alternative.
3. Click OK.

A New Alternative message box displays, stating, “Alternative successfully created.”
4. Click OK.

The data frame redisplays.

Copying an Alternative

Use the following procedure to make a copy of an alternative. [This functionality'is currently being
verified.]

1. Inthe SBAS Toolbar, select Alternative>Copy Alternative.
A Copy Alternative dialog displays.

2. From the Select Alternative to Copy drop-downlist box, select the alternative that you want to
copy.

The Cell Layer Name and Fluxikayer Name text boxes automatically populate with the
associated layers.

3. Click Copy.

An Enter Alternative Name dialog displays.
4. Inthe text box, type a name for.the alternative.
5. ClickOK.

The data frame redisplays.

Opening an Existing Alternative

Use the following procedure to load an existing alternative. [This functionality is currently being
verified.]

1. Open a saved ArcMap project file (mxd).

All sediment budget littoral cells and flux lines should be displayed.
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2. Inthe SBAS Toolbar, select Alternative>Load Project Alternative.
A Browse to Alternative dialog displays.
Note: The associated alternative file must be loaded before you can add any more cell and flux
values.

3. Browse to the location of the alternative file associated with the sediment budget layers.
Note: If you don’t remember the associated alternative file name, the file path and name are
tagged in the SBAS_File field of the layer’s attribute table.

Name Heszidual mﬁlﬂ
b yLittaralCell_1 24 | C:Abermphrnys BASfile. zbd
4. Click OK.
The alternative is loaded.
You can now edit the sediment budgetiin the SBAS environment.
Loading an SBAS Layer

Use the following proceddre to load an existing littoral cell or flux layer.

1.

Open a saved ArcMap projectfile tmxd):

All sediment,budget littoral cells and flux lines should be displayed.

2. In the SBAS Toolbar, select Budgets>Load SBAS Layer.
An Add Data dialog displays.
3. Select the appropriate layer (.shp) file.
4. Click Add.
The data frame redisplays with the selected layer added to the ArcMap Table of Contents and
the data frame.
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Using SBAS-Standalone Files in SBAS for ArcGIS 10

Because SBAS-Standalone is interoperable with ArcGlIS, you can import shapefiles into SBAS-
Standalone and use them as a basemap when creating littoral cells and fluxes. This type of
spatially enabled file assigns a coordinate system, so the sediment budget lies in the appropriate

geographic space.

If a coordinate system has been assigned, sediment budgets you create using SBAS-Standalone
can easily be exported for use with ArcGIS/ArcMap 10. Use the following precedure to export an
SBAS-Standalone file for use in ArcGIS/ArcMap 10 with the SBAS Toolbar:

Open the SBAS-Standalone file (*.sbs).

B SBAS - Duv_Vol_sed.sbs

File Edit View Zoom Draw Mass Help

DEH 4 bR |80 XA (15 GLMe0TN aRi%

Alternatives I Summary |

-Alternative 1

Colors | Rate Graphsl Fonts I Sizes l Fills |
'

Property Color
Flux Color

FluxBorder Color

Cell Border Color

Gain Color

Loss Color

Balanced Color

Cell Label Color Y

Placement Label Calor ‘ L‘;v [ »
East=661392.86, North=654493.69, Distance =27387.23 ft Ny NUM | 4
S

From the SBAS-Standalone
Fileimenu select Export
ArcView SBAS File.

.. Choose a name for the SBAS Control file

}Savein: I | ArcGIS_Export j & £ Ev

-~

Name
No items match your search.

A Choose a Name for the SBAS |
Control Filedialog displays.

< | 1] »

Ll Cancel

File name: IDquoIAIt

Save as type: ISBAS Control Files
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3. Inthe File Name text box, type a name for the SBAS control file you're exporting.
4. Click Save.

The SBAS-Standalone file is exported with a .sbd extension. This file holds all of the alternative
data, such as dV and placement values.

Two shapefiles (*.shp) are also created—one for the polygon littoral cells and the other for the
polyline fluxes—and saved in the same location using the same name you provided for the
.sbd file name (for example, Mobile Bar.sbd, Mobile Bar_cells.shp, an ile Bar_fluxes.shp).

5. Close SBAS-Standalone.
6. Open ArcMap.
7. Create a new MXD file.

8. Inthe ArcMap Standard
toolbar, click the ArcMap (b
(Add Data) button.

' Add Data

An Add Data dialog displays.

9. Locate and select the cell
shape file exported in st

10. Click Add.

11

. The littoral cell laye o

Show of type: | patasets and Layers V] [ Cancel ]

12.
13. Locate and select the flux shape file exported in step 4.
14. Click Add.

15. The flux layer is added to the ArcMap Table of Contents.
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16. In the SBAS Toolbar, select Alternative> Atemative Loaded

Load Project Alternative.

@ Alternative: ALTERNATIVE 1, from
b C:\Users\kSopjrd3\Documents\_Projects\eCoastal\SBAS-A\SAJ\Fr

This is required in order to view the full detail OomSANAICGIS_Export\DuwolAltsbd
has successfully loaded for layer: DUVVOLALT_FLUXES.
of the alternative.

A message box displays, stating “Alternative:
AlternativeName, from location has successfully
loaded for layer: LayerName!

17. Click OK.

18. View details of the alternative:
nfyr

a. Selecta layerin the Table Varebe

SOURCE FLUXES
of Contents. pos

SINK FLUXES
Q10

b. Select afeature in the map |||V

Placement

H Removal . N/A
display. coriny | P
X 0

10
N/A
N/A

c. From the SBAS Toolbar,
select Edit>Edit Cell/Flux
Values.

A Cell Properties di

4. Click OK.

File Path/Name:
C:\Users\k5opjrd3\Documents\Alternative.sbd

Save Altemativ][ Cancel ]

7. When you're done working with ArcMap, close the application.
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Using SBAS Toolbar Files in SBAS-Standalone

Use the following procedure to import a sediment budget (alternative and geometry) created in
ArcMap/ArcGIS 10 with the SBAS Toolbar into SBAS-Standalone.

1. In SBAS-Standalone, select
File>Import ArcView SBAS File. \\

"

|

B Select the SBAS control file

Look in: I | Sarasota Z| & £ Ev

~

A Select the SBAS Control File Name
dialog displays. || ALT-00:sbd

2. Locate and select the
alternative (*.sbd file) that you
previously created using SBAS || <!
Toolbar in ArcGIS/ArcMap 10. [§l File name:

Files of type:

3. Click Open.

A Select the Cell Shape File Z| « @k @y

dialog displays.

~

4. Locate and select the
cell shapefile (*.shg
alternative.

File name: |Cells.shp

Files of type: IESRI Shape Files (*.shp)

[~ Open as read-only
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5. Click Open.

The Cell Shape File dialog
redisplays.

6. Locate and select the flux
shapefile (*.shp) for the
alternative.

7. Click Open.

A Project Properties dialog displays.

8. Enter the project properties.

B Select the cell shape file

Look in: I | Sarasota

Name
| Cells.shp
| dV_Results.shp
E | Flux.shp

<« 1l

‘ File name: |Fluxshp

Files of type: |ESRI Shape Files (*.shp)

[~ Open as read-only

—Q Units of rr

" cum
" cuyd

 cumfyr

—Uncertainty calculation type

® RMS " Max
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9. Click OK.

The sediment budget and alternative values are now available in SBAS-Standalone.

"‘,.‘W',‘V‘e-"mm"”'“__"","’ — = - - = -
D@ iR - @ OQAXAAA(5-|SGWOTTN s BRE R PFK e e@ L 8w 2R

Atemetves | Summary |
B At
B Cals
21
® Source Fluxes
Sk Flunes:

::%4
Colagsed Cals
# Fhues

Cabors | Reta Graphs | Foms | Saes |Fils | |

. Balance Crisaria.
| @ CellResidudl  C Calldy k SOURCE FLUXES
SINK FLUXES

Apply o Salecied Objpcts
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